Search Forums
Forums
Kiwitrees on Twitter
    Tags

    3.3.2, duplicates, image, clipboard, husband, re-order, last change date, simpl_research, github, 3.2.3, REFN, sidebar, lists individuals families, custom text, MAC, descendants, Histo, place, .po, prefix, simpl_pages, translate, 2.0.2, emigration, FAQ, index, formatting, widget, fancy image bar, Search and replace, advent, icons, spam, fact, nickname, blocks, installation, button, prison, BAPM, 3.1, edit interface, multiple marriages, living, research tasks, dropbox. token, lists, help, future, watermark, order, NCHI, custom modules, Favourites 3.0.0, BURI, performance, locked out, Require visitor authentication, family fact, abbreviate

    Tagged: , ,

    Topic:   Upgrade to 3.2.1 breaks display before menus shown  

    This topic contains 9 replies, has 3 voices, and was last updated by  jacoline 1 year, 8 months ago.

    Viewing 10 posts - 1 through 10 (of 10 total)
    • Author
      Posts
    • #6206
      pab
      pab
      Participant

      139 posts

      Upgraded twice. Caches cleared. Site does not load beyond fancy image bar. No blocks. No menus. No login.

      Penguins Are Boss

      Apache 2.4.25; MariaDB 10.1.22; PHP 7.0.18

      http://bootesgowland.info

      #6207
      kiwi
      kiwi
      Keymaster

      1595 posts

      Have a look in your server’s error log. I would expect an error of that magnitude to have an entry there.

      Nigel
      My personal kiwitrees site is www.our-families.info
      #6210
      pab
      pab
      Participant

      139 posts

      Error log is full of these lines:

      [15-Apr-2016 18:38:57 UTC] PHP Fatal error: Call to undefined method WT_MenuBar::getCalendarMenu() in /home/gowland/public_html/kiwitrees/modules_v3/menu_calendar/module.php on line 55
      [15-Apr-2016 18:38:57 UTC] PHP Fatal error: Call to a member function getClientIp() on null in /home/gowland/public_html/kiwitrees/includes/session.php on line 350

      Pairs repeatedly occurring.

      Penguins Are Boss

      Apache 2.4.25; MariaDB 10.1.22; PHP 7.0.18

      http://bootesgowland.info

      #6212
      kiwi
      kiwi
      Keymaster

      1595 posts

      Delete the folder “modules_v3/menu_calendar/”. It should have self-deleted during the upgrade though.

      Nigel
      My personal kiwitrees site is www.our-families.info
      #6213
      pab
      pab
      Participant

      139 posts

      Thanks Nigel, that seems to have been the problem. The folder had not been deleted during the upgrade. A permissions or owner issue maybe?

      Penguins Are Boss

      Apache 2.4.25; MariaDB 10.1.22; PHP 7.0.18

      http://bootesgowland.info

      #6215
      kiwi
      kiwi
      Keymaster

      1595 posts

      Yes, that would be the only thing I can think of. Very unusual. Glad it’s OK now though.

      Nigel
      My personal kiwitrees site is www.our-families.info
      #6232
      kiwi
      kiwi
      Keymaster

      1595 posts

      After further thought, I’ve realised what the problem probably was, and it’s not a permissions issue. Deleting no longer required files / folders (such as “modules_v3/menu_calendar/”) only happens when you visit the administration pages.

      I’ve now added this paragraph to the upgrade instructions to clarify the issue:

      There are no special requirements if you are upgrading from any version later than 3.0.0. but you are likely to find initially that you have no menus displayed. To fix this login (if necessary set your browser URL to your-domain/login.php to do this), and visit the administration pages. Just visiting there is sufficient to complete the upgrade process and allow the menus to display normally again.

      Nigel
      My personal kiwitrees site is www.our-families.info
      #6233

      jacoline
      Participant

      479 posts

      There are no special requirements if you are upgrading from any version later than 3.0.0. but you are likely to find initially that you have no menus displayed. To fix this login (if necessary set your browser URL to your-domain/login.php to do this), and visit the administration pages. Just visiting there is sufficient to complete the upgrade process and allow the menus to display normally again.

      Another dane and I had the issue with one of my installations too. Even if we setup the login we can not access the page. Since we did not knew the cause of the problem – we just /del all beside /data folder! So I think we just might to /delete the calender folder.

      Regards,
      Jamie Jaconelli

      admin and owner of:
      www.jaconelli.dk/webtrees, www.jaconelli.dk/history, www.familien-johnsen.dk(submenu) and danish support at www.host-siden.dk/sandbox and facebook

      #6237
      kiwi
      kiwi
      Keymaster

      1595 posts

      Thanks. I’ll add that information in case others have the issue. What theme were you using when you could not access login even with the URL?

      Nigel
      My personal kiwitrees site is www.our-families.info
      #6248

      jacoline
      Participant

      479 posts

      kiwitrees – same with the other dane

      but….

      the other installation with kiwitrees theme did not fail – So I am not sure it is a theme issue

      Regards,
      Jamie Jaconelli

      admin and owner of:
      www.jaconelli.dk/webtrees, www.jaconelli.dk/history, www.familien-johnsen.dk(submenu) and danish support at www.host-siden.dk/sandbox and facebook

    Viewing 10 posts - 1 through 10 (of 10 total)

    You must be logged in to reply to this topic.