Search Forums
Forums
Kiwitrees on Twitter
    Tags

    re-order, access level, relationships, GEDCOM, Default record, Require visitor authentication, .po, errors, googlemap, research tasks, error, cousin tab, marriages, 3.0.0. setup, sidebar, 3.2.2, HTML block, save settings, kiwitrees, mobile, calendar, immigration, custom modules, Add a wife, timeout, menus, clipboard, translation, 1939 Register, Themes change, repo, cousins, mysql5.7, IE problem, 3.0.0 widgets, block, advanced, googlemaps, future, image, prefix, gallery, custom text, simpl_pages, translate, Georgian, html, link, zend, message contactform, sanity checker, watermark, bug reporting, person, internal messaging, order, seo, edit interface, simpl_research, modules

    Topic:   Type for media  

    This topic contains 14 replies, has 2 voices, and was last updated by kiwi kiwi 6 months, 1 week ago.

    Viewing 15 posts - 1 through 15 (of 15 total)
    • Author
      Posts
    • #7574

      jacoline
      Participant

      408 posts

      If I do not choose any type it will be “photo” when adding. When I use the media list it is shown as “other”

      Why can I not get it as “empty” ? (or a least photo as it was added)

      Anything in the gedcom which preventing not using a real “empty” type? (if empty it will not be shown in album, the gallery ect) I have some media which is just an info picture so an empty type would be usefull for me πŸ™‚

      Regards,
      Jamie Jaconelli

      admin and owner of:
      www.jaconelli.dk/webtrees, www.host-siden.dk/history, www.familien-johnsen.dk and danish support at www.host-siden.dk/sandbox

      #7575
      kiwi
      kiwi
      Keymaster

      1443 posts

      You are right, it should be possible. I will look into it before the next release,

      Nigel

      My personal kiwitrees site is www.our-families.info

      #7579
      kiwi
      kiwi
      Keymaster

      1443 posts

      Just looked at this. Did you try selecting the blank option at the top of the list?
      Screenshot-2016-12-19-17.07.34

      This works for me. It means nothing is entered in the TYPE field.

      ‘Photo’ is the default because it is the most commonly used. I would not want to change that.

      Nigel

      My personal kiwitrees site is www.our-families.info

      Attachments:
      You must be logged in to view attached files.
      #7585

      jacoline
      Participant

      408 posts

      It is the media list πŸ™‚ Not the creation of the media.
      Sorry! My fault – it was not made quite clear in my post!

      But I still want to be able to make a “empty” type

      Regards,
      Jamie Jaconelli

      admin and owner of:
      www.jaconelli.dk/webtrees, www.host-siden.dk/history, www.familien-johnsen.dk and danish support at www.host-siden.dk/sandbox

      #7586
      kiwi
      kiwi
      Keymaster

      1443 posts

      You can create an empty TYPE as I showed.
      If that’s not the problem please explain fully.
      I’m not aware of any problem with the media list now I have fixed that bug.

      Nigel

      My personal kiwitrees site is www.our-families.info

      #7587

      jacoline
      Participant

      408 posts

      Use medialist.
      Choose empty and the list will show the type as “other” instead

      Regards,
      Jamie Jaconelli

      admin and owner of:
      www.jaconelli.dk/webtrees, www.host-siden.dk/history, www.familien-johnsen.dk and danish support at www.host-siden.dk/sandbox

      #7588
      kiwi
      kiwi
      Keymaster

      1443 posts

      OK great. I see the problem now. Selecting no type in media list actually displays ALL types and also displays type as “Other”. So I have added a new option to select “No type”:

      Screenshot-2016-12-20-10.27.57

      Unfortunately this requires a few file changes so I’m not able to provide updates here. It will be included in the next release.

      Nigel

      My personal kiwitrees site is www.our-families.info

      Attachments:
      You must be logged in to view attached files.
      1 user thanked author for this post.
      #7592

      jacoline
      Participant

      408 posts

      /smile no worries and no rush!

      But it could be great if I could choose to have it as “empty” when I add it. So I can choose “empty” or defined as “no type”. It is fine that default is photo!

      You showed me that I can add it as “empty” but it still use “photo” when you save the media! Atleast if you edit the media (have not tried when I add and see if it keeps the “no type” option!

      Regards,
      Jamie Jaconelli

      admin and owner of:
      www.jaconelli.dk/webtrees, www.host-siden.dk/history, www.familien-johnsen.dk and danish support at www.host-siden.dk/sandbox

      #7593
      kiwi
      kiwi
      Keymaster

      1443 posts

      You showed me that I can add it as β€œempty” but it still use β€œphoto” when you save the media! At least if you edit the media (have not tried when I add and see if it keeps the β€œno type” option!

      For me it works the same whether adding new media or editing existing. Select the top (blank) item from the drop down list and it will save with no TYPE.

      Nigel

      My personal kiwitrees site is www.our-families.info

      #7594

      jacoline
      Participant

      408 posts

      I will have to wait for next release! Can not test it – but looks like we can use “unused” in the future πŸ™‚

      Regards,
      Jamie Jaconelli

      admin and owner of:
      www.jaconelli.dk/webtrees, www.host-siden.dk/history, www.familien-johnsen.dk and danish support at www.host-siden.dk/sandbox

      #7597
      kiwi
      kiwi
      Keymaster

      1443 posts

      Ignore me 🙂

      OK πŸ™‚

      Nigel

      My personal kiwitrees site is www.our-families.info

      #7598

      jacoline
      Participant

      408 posts

      You managed to read my answer before edit πŸ™‚ You have the last change in your files so I can not test if it works – I just had to read you repsond earlier where you told you have changed alot of files πŸ™‚ sorry for my mistake

      Regards,
      Jamie Jaconelli

      admin and owner of:
      www.jaconelli.dk/webtrees, www.host-siden.dk/history, www.familien-johnsen.dk and danish support at www.host-siden.dk/sandbox

      #7599
      kiwi
      kiwi
      Keymaster

      1443 posts

      You managed to read my answer before edit 🙂 You have the last change in your files so I can not test if it works – I just had to read you repsond earlier where you told you have changed alot of files 🙂 sorry for my mistake

      Sorry but your assumption is wrong. This is NOT related to the other changes I have just made. They relate ONLY to the bug they are attached to – the media list not remembering your settings when you move to a second page.

      I have just, using an absolutely standard 3.2.3 installation:
      1 – Added a new media object with no TYPE (by selecting the blank space at the top of the TYPE selection) – SUCCESS.

      1 FILE Screenshot test.png
      2 FORM png
      1 _PRIM N

      2 – Edited that media item to give it a TYPE = photo – SUCCESS

      1 FILE Screenshot test.png
      2 FORM png
      2 TYPE photo
      1 _PRIM N

      3 – Edited that media item to remove the TYPE (by selecting the blank space at the top of the TYPE selection) – SUCCESS.

      1 FILE Screenshot test.png
      2 FORM png
      1 _PRIM N

      If that is not happening on your system then there is a different problem. But my guess is that the three things I tried above are not the same as you are doing.

      Nigel

      My personal kiwitrees site is www.our-families.info

      #7600

      jacoline
      Participant

      408 posts

      I have done excactly like you and it is still photo as type πŸ™‚ That is the reason I got the idea it was a change in your files!

      Regards,
      Jamie Jaconelli

      admin and owner of:
      www.jaconelli.dk/webtrees, www.host-siden.dk/history, www.familien-johnsen.dk and danish support at www.host-siden.dk/sandbox

      #7601
      kiwi
      kiwi
      Keymaster

      1443 posts

      You must be doing something wrong, I think.

      I have just been to your site and changed M345 from TYPE photo to no TYPE. You can see that on the page: http://www.host-siden.dk/history/mediaviewer.php?mid=M354&ged=Historic#

      You will also see the change on your log (Administration > Family tree tools > Changes log).

      Attached here are screen images of each step. (you can see the times of each in the file names).

      Nigel

      My personal kiwitrees site is www.our-families.info

      Attachments:
      You must be logged in to view attached files.
    Viewing 15 posts - 1 through 15 (of 15 total)

    You must be logged in to reply to this topic.