Search Forums
Forums
Kiwitrees on Twitter
    Tags

    not married, surname, 3.2.0, calendar, sanity checker, add missing death, ADDR, children, sidebar, chart, family, GEDCOM errors, bug reporting, defacto, survey, MAC, login, 3.3.1 Notes, illegitimate, 3.2.1, Themes change, progress, admin, error, cousin tab, ID notes, autocomplete, repo, fixing errors, type, source, individual resource, Export/Import, road map, Histo, name, abbreviate, style, menus, merge, request, lists individuals families, Batch Updates, save settings, tags, title, fancy tree view, data errors, husband, wish, event, address, php 7, batch update, census assistant, Favourites 3.0.0, date, administration pages, library, marriage

    Topic:   Site threw up  

    This topic contains 8 replies, has 2 voices, and was last updated by macalter macalter 2 years, 4 months ago.

    Viewing 9 posts - 1 through 9 (of 9 total)
    • Author
      Posts
    • #4806
      macalter
      macalter
      Participant

      550 posts

      ERROR 2: Cannot modify header information – headers already sent by (output started at /home/user/royalty.woodengems.com/edituser.php:92)

      Warning: Cannot modify header information – headers already sent by (output started at /home/user/royalty.woodengems.com/edituser.php:92) in /home/user/royalty.woodengems.com/library/WT/Controller/Page.php on line 178

      I’m seeing this when I go to Administration pane above the blue barl. Last actions were:

      to change view raw GEDCOM for members back to no view (was trying to create a special account for me)

      In FTP, duplicated xenea/images/facts folder and moved it to xenea/myFactsImages. Was going to try your suggestion so made duplicate while reading a duplicated style.css (mystyle.css) to find reference to these images. (deleted the file)

      ERROR LOG: ERROR 2: Cannot modify header information – headers already sent by (output started at /home/user/royalty.woodengems.com/edituser

      -----
      Kiwitrees:
      "A-D connections 3.3.1"
      PHP 7.0 Fast CGI

      "The Royals 3.3.1"
      PHP 7.0 Fast CGI
      mySQL server: 5.1.56
      MacOS: 10.11.6  (El Capitan)
      Browsers (mac): Safari  Version 11.0;  Firefox 56.0
      [updated: 07 Oct 2017]

      #4807
      kiwi
      kiwi
      Keymaster

      1547 posts

      First – the error is about changing some thing in the user admin, so the two actions you describe (change view raw GEDCOM for members back to no view ; and In FTP, duplicated xenea/images/facts folder and moved it to xenea/myFactsImages.) are not involved.

      Something went wrong during your attempt to create or modify a new user’s account details.

      I can see the error messages in the log file, but I can’t see what you are doing to cause them. Can you carefully recreate the error message and tell me precisely at what point the error occurrs?

      Nigel
      My personal kiwitrees site is www.our-families.info
      #4809
      macalter
      macalter
      Participant

      550 posts

      I know the Admin page doesn’t have a theme which is strange because the page is /edituser.php. It appears above my user account. I was modifying editor account level versus privileges in modules.

      The error log as you saw shows about 5pm (my time) tonight but wasn’t found because the INDI pages are okay so only appeared when I tried modifying the account.

      I blocked out portion of the path in the image.

      -----
      Kiwitrees:
      "A-D connections 3.3.1"
      PHP 7.0 Fast CGI

      "The Royals 3.3.1"
      PHP 7.0 Fast CGI
      mySQL server: 5.1.56
      MacOS: 10.11.6  (El Capitan)
      Browsers (mac): Safari  Version 11.0;  Firefox 56.0
      [updated: 07 Oct 2017]

      Attachments:
      #4811
      kiwi
      kiwi
      Keymaster

      1547 posts

      OK, that’s great, thanks. I’ll see what I can find from that.

      Nigel
      My personal kiwitrees site is www.our-families.info
      #4812
      kiwi
      kiwi
      Keymaster

      1547 posts

      Found the problem. I put some lines of code in the wrong place at a recent tidy up. It doesn’t stop anything from functioning, but does need fixing anyway.

      Attaches is a replacement “edituser.php” file for this bug.

      Nigel
      My personal kiwitrees site is www.our-families.info
      Attachments:
      #4815
      macalter
      macalter
      Participant

      550 posts

      Wonderful!!! I had to use history to find the page, couldn’t quite remember my steps 🙂
      Now, did the throw up affect my backup USB drive? It’s not working <LOL!>

      -----
      Kiwitrees:
      "A-D connections 3.3.1"
      PHP 7.0 Fast CGI

      "The Royals 3.3.1"
      PHP 7.0 Fast CGI
      mySQL server: 5.1.56
      MacOS: 10.11.6  (El Capitan)
      Browsers (mac): Safari  Version 11.0;  Firefox 56.0
      [updated: 07 Oct 2017]

      #4816
      macalter
      macalter
      Participant

      550 posts

      Wait a minute — I have no menu items! There were buttons before the throw up.

      -----
      Kiwitrees:
      "A-D connections 3.3.1"
      PHP 7.0 Fast CGI

      "The Royals 3.3.1"
      PHP 7.0 Fast CGI
      mySQL server: 5.1.56
      MacOS: 10.11.6  (El Capitan)
      Browsers (mac): Safari  Version 11.0;  Firefox 56.0
      [updated: 07 Oct 2017]

      #4817
      kiwi
      kiwi
      Keymaster

      1547 posts

      Menus all look fine on your Royals site to me.

      Nigel
      My personal kiwitrees site is www.our-families.info
      #4818
      macalter
      macalter
      Participant

      550 posts

      Okay, they came back. No idea how.

      -----
      Kiwitrees:
      "A-D connections 3.3.1"
      PHP 7.0 Fast CGI

      "The Royals 3.3.1"
      PHP 7.0 Fast CGI
      mySQL server: 5.1.56
      MacOS: 10.11.6  (El Capitan)
      Browsers (mac): Safari  Version 11.0;  Firefox 56.0
      [updated: 07 Oct 2017]

    Viewing 9 posts - 1 through 9 (of 9 total)

    You must be logged in to reply to this topic.