Search Forums
Forums
Kiwitrees on Twitter
    Tags

    husband, My Page, pages, 3.2.3, .po, 3.0.0. setup, 3.3.1, married, advanced, ID notes, defacto, Batch Updates, kiwitrees 2.0.2, nickname, Georgian, translation, 2.0, database, links, not married, language, release, webtrees 1.4.4.1, road map, pdf, flags, spouse, lists individuals families, simpl_pages, census assistant, blocks, notes, duplicates, Histo, ID facts, index, 1939 Register, users, GEDCOM, 3.2.1, dates, HTML block, login upgrade, pending, sanity checker, F.A.B., timeout, merge, custom text, 3.3.0, wish, translate, Search and replace, check, errors, fancy image bar, census, statistics, edit menu, edit interface

    Topic:   Session handler  

    This topic contains 24 replies, has 2 voices, and was last updated by  jacoline 3 days, 14 hours ago.

    Viewing 15 posts - 1 through 15 (of 25 total)
    • Author
      Posts
    • #9453

      jacoline
      Participant

      455 posts

      Getting this and I have no idea how to fix it ๐Ÿ™

      ERROR 2: Unknown: Cannot call session save handler in a recursive manner
      0 Error occurred on

      Regards,
      Jamie Jaconelli

      admin and owner of:
      www.jaconelli.dk/webtrees, www.jaconelli.dk/history, www.familien-johnsen.dk(submenu) and danish support at www.host-siden.dk/sandbox and facebook

      #9454
      kiwi
      kiwi
      Keymaster

      1575 posts

      I have fixed a couple of similar errors recently, so I expect that yours will be fixed with the next upgrade (3.3.2). That should be available by the e3nd of this week if you can wait that long ๐Ÿ™‚

      Nigel
      My personal kiwitrees site is www.our-families.info
      #9455

      jacoline
      Participant

      455 posts

      I can not open my page cause of this ๐Ÿ™

      Regards,
      Jamie Jaconelli

      admin and owner of:
      www.jaconelli.dk/webtrees, www.jaconelli.dk/history, www.familien-johnsen.dk(submenu) and danish support at www.host-siden.dk/sandbox and facebook

      #9456
      kiwi
      kiwi
      Keymaster

      1575 posts

      What page?

      Nigel
      My personal kiwitrees site is www.our-families.info
      #9457

      jacoline
      Participant

      455 posts

      jaconelli.dk/webtrees

      Frontpage is empty and if you hit a menu to get data you will get the error

      Regards,
      Jamie Jaconelli

      admin and owner of:
      www.jaconelli.dk/webtrees, www.jaconelli.dk/history, www.familien-johnsen.dk(submenu) and danish support at www.host-siden.dk/sandbox and facebook

      #9458
      kiwi
      kiwi
      Keymaster

      1575 posts

      Ouch – that’s a major problem! The issues I recently fixed were minor in comparison, just affecting small parts of a couple of pages I was working on.

      It’s not likely to be a problem with kiwitrees – unless you have been making changes to the code, which I very much doubt. But it’s impossible for me to see what is happening, as even your administration pages are affected by the problem. Even the error message only shows what you reported above – which is cut-off and of no help, except that as the problem has also affected the PHP error message, then it is even more likely to be a server issue.

      My suspicion is a change either to your server or perhaps to the Joomla you also have running (I’ve seen a lot of similar reports related to Joomla).

      The first step is to have a look at your server error logs. See if there are any reports indicating what happened just before this error started to appear.

      Another thought – what version of PHP are you using? Not 7.2 I hope??

      Nigel
      My personal kiwitrees site is www.our-families.info
      #9459

      jacoline
      Participant

      455 posts

      I just remove it and upload a backup. As it worked yesterday ๐Ÿ™‚
      Can not wait until sunday and will not ask you so close to an upgrade

      No worries ๐Ÿ™‚

      Regards,
      Jamie Jaconelli

      admin and owner of:
      www.jaconelli.dk/webtrees, www.jaconelli.dk/history, www.familien-johnsen.dk(submenu) and danish support at www.host-siden.dk/sandbox and facebook

      #9460
      kiwi
      kiwi
      Keymaster

      1575 posts

      If it worked yesterday, and you haven’t changed sny kiwitrees files, then i cannot understand how replacing a kiwitrees backup will help. It will surely ge the same?

      You shoukd talk to your webhost. It is most likely they have changed something at the server.

      Nigel
      My personal kiwitrees site is www.our-families.info
      #9461

      jacoline
      Participant

      455 posts

      No I broke the session handler by doing this: (and my backup works)

      I have created the fancy reports in a menu (for ancestors) and I was about to make similar for decendents.
      I copied the extra_menu and renamed it the new module name as I have done for the others. It did not show in the module list so I tried again. And I think I copied and renamed from the fancy report for ancestor menu I made this time. All the time I was logged in. This time after it showed in the list. And as disabled. And still while I was logged in I made the changes in my userdefined language file and after uload of this I would hit the “clear cache” and then I got the session handling error.

      It does somehow makes sense to me! (in a way) Because the module was created in the database with errors but it did not help to edit the database and removing them (it was made in 4 lines with a 1 and -1 in the table). So I had to remove the standard kiwitrees files in modules, includes, js, lib and the admin files in the root with my db backup.

      Regards,
      Jamie Jaconelli

      admin and owner of:
      www.jaconelli.dk/webtrees, www.jaconelli.dk/history, www.familien-johnsen.dk(submenu) and danish support at www.host-siden.dk/sandbox and facebook

      #9462

      jacoline
      Participant

      455 posts

      Btw I started to test the backup by using the php 7.2 and it worked there. So I made the same changes at 7.1 where I have my installation and as expected working too. You are welcome to look at php7.2 installation if you want to. I can also make some test for you. But ………………. the connection with ftp to php7.2 is not stable. When I delete a big amount of data I get dissmissed and have to relog. No problems in just uploading!

      This is only f.y.i

      Regards,
      Jamie Jaconelli

      admin and owner of:
      www.jaconelli.dk/webtrees, www.jaconelli.dk/history, www.familien-johnsen.dk(submenu) and danish support at www.host-siden.dk/sandbox and facebook

      #9464
      kiwi
      kiwi
      Keymaster

      1575 posts

      You are welcome to look at php7.2 installation if you want to. I can also make some test for you.

      Thanks, but it will be 6 months I expect before I’m ready to look at 7.2.

      Nigel
      My personal kiwitrees site is www.our-families.info
      #9465
      kiwi
      kiwi
      Keymaster

      1575 posts

      I made the changes in my userdefined language file

      Are you aware that these language files are no longer required (in most cases)? You can use Administration > Site administration > Custom translation. This stores the translations in the database and avoids any complications with extra files.

      Nigel
      My personal kiwitrees site is www.our-families.info
      #9468

      jacoline
      Participant

      455 posts

      I made the changes in my userdefined language file

      Are you aware that these language files are no longer required (in most cases)? You can use <em class=”gdbbx-bbcode-italic”><strong class=”gdbbx-bbcode-bold”>Administration > Site administration > Custom translation. This stores the translations in the database and avoids any complications with extra files.

      I know thank you. But it does not work at my “pages” titles which is not core titles. Might be to complex: https://www.jaconelli.dk/webtrees/module.php?mod=pages&mod_action=show&pages_id=241&lang=en_US and I can not use both

      Regards,
      Jamie Jaconelli

      admin and owner of:
      www.jaconelli.dk/webtrees, www.jaconelli.dk/history, www.familien-johnsen.dk(submenu) and danish support at www.host-siden.dk/sandbox and facebook

      #9469
      kiwi
      kiwi
      Keymaster

      1575 posts

      You do not need to use translation files for “pages”. Just created two copies of each “page” – one for only Danish, and one for only US American. The titles and the content can be correct for each language then.

      Why do you say “I can not use both”? I do not understand what problem that can be.

      Nigel
      My personal kiwitrees site is www.our-families.info
      #9470

      jacoline
      Participant

      455 posts

      BTW out of record. Can you give me a hint how to use the background-image: url(../images/sprites-top-menu.png)
      EX: I would use the menu-chart sub chart familybook in my userdefined menu instead of making an icon each time I want to have a userdefined menu

      Regards,
      Jamie Jaconelli

      admin and owner of:
      www.jaconelli.dk/webtrees, www.jaconelli.dk/history, www.familien-johnsen.dk(submenu) and danish support at www.host-siden.dk/sandbox and facebook

    Viewing 15 posts - 1 through 15 (of 25 total)

    You must be logged in to reply to this topic.