Search Forums
Forums
Kiwitrees on Twitter
    Tags

    Extra menus, simpl_pages, php 5.6, mail, nickname, birth, request, GEDCOM errors, batch update, github, survey, editor, contacts, googlemap, logout, translation, administration pages, google, json, living, translate, charts, advanced, mysql5.7, event, css, emmigration, colors theme, check, performance, defacto, blocks, message contactform, dead, Fancy imagebar, place, themes, menus, webtrees 1.4.4.1, marriages, simpl_research, error, language, Themes change, add, link, kiwitrees, statistics, 3.3.0, tools, individual resource, Add a wife, family, sanity, upgrade, roadmap, partner, research tasks, custom, FAQ

    Topic:   New account – no approval request  

    This topic contains 7 replies, has 2 voices, and was last updated by  jamesl 2 years ago.

    Viewing 8 posts - 1 through 8 (of 8 total)
    • Author
      Posts
    • #4456

      jamesl
      Participant

      22 posts

      Hello all,

      I have a problem with requests for a new user account. The new user receives a message concerning the request and the entry in the user table is created when the user clicks on the confirmation link. However, as admin I never receive the message asking to approve the account.

      There is already a topic describing similar behaviour:
      https://kiwitrees.net/forums/topic/email-notice-of-new-account-request/
      but there didn’t appear to be a clear diagnosis of what was causing the problem.

      I am able to receive messages (by email) sent from other user accounts.so message delivery seems to be working.

      #4457
      kiwi
      kiwi
      Keymaster

      1443 posts

      James, this problem is is usually caused by incorrect mail settings.

      Can you provide your settings, from two places:
      1 – admin>site admin>mail config
      2 – Family trees >your family tree>general>kiwi trees reply address

      Nigel

      My personal kiwitrees site is www.our-families.info

      #4458

      jamesl
      Participant

      22 posts

      Thanks for the prompt reply Nigel.

      admin -> Site config -> mail config:
      Server name: smtp.gmail.com
      Port number: 995
      use password: yes
      Password: xxxxx
      Secure connection: ssl
      sending server name: loveluck:net

      Family trees >your family tree>general>kiwi trees reply address
      kiwitrees-noreply@loveluck.net

      Hope that helps clarify the problem.

      James

      #4459
      kiwi
      kiwi
      Keymaster

      1443 posts

      Ah, a gmail user 🙂

      Gmail doesn’t like emails sent with a fictitious rely address. Try changing kiwitrees-noreply@loveluck.net to a ‘real’ email address.

      Also, although it is not likely to be causing any issues related to this problem, is your sending server name really loveluck:net? Shouldn’t it be loveluck.net (note dot in mine vs colon in yours)? But I suspect that may be just a typo in your forum post.

      Nigel

      My personal kiwitrees site is www.our-families.info

      #4460

      jamesl
      Participant

      22 posts

      Thanks Nigel. I changed the reply address to a genuine address and everything works fine now.

      The colon was just a typo, it was correct as loveluck.net in the mail configuration.

      #4461

      jamesl
      Participant

      22 posts

      There’s still one point I don’t really understand.

      With PhpGedView I was able to configure it (on the same web site) such that the message to the new user, with subject ‘Your Registration ..” and the message to the administrator, with subject ‘New User at …” were both sent with the From address phpgedview-noreply@loveluck.net. With Kiwitrees, it seems I have to use a regular email address for the kiwitrees reply address, and this means that the messages now have this regular email address as the From address. Is it not possible to configure Kiwitrees such that kiwitrees-noreply@loveluck.net is the From address for these messages?

      To avoid any confusion, I should mention that I’m talking here about the email messages (I’ve configured my account to use internal messaging and email) – the internal messages have always been delivered correctly, but I would like to be alerted by email when there are new user requests.

      James

      #4462
      kiwi
      kiwi
      Keymaster

      1443 posts

      Is it not possible to configure Kiwitrees such that kiwitrees-noreply@loveluck.net is the From address for these messages?

      James, did you miss the part of my original response that said “Gmail doesn’t like emails sent with a fictitious rely address.” ?

      Its not a problem in kiwitrees. As far is it is concerned you can set the “From” email address to anything you want. But, as you have already discovered, if you set it to a non-verifiable address Gmail (and a number of other mail providers) will reject it.

      It is not the “noreply” part that causes the problem. It is that Gmail cannot verify your From address as a genuine email address. If you create an email account that really does have the name kiwitrees-noreply@loveluck.net then it should work OK.

      As to why you used to be able to do it in PGV, that’s because it is only relatively recently that the major email service providers have been tightening down hard on spam email. The email code in kiwitrees is not fundamentally different to what it was in PGV, Gmail just responds to it differently now.

      Nigel

      My personal kiwitrees site is www.our-families.info

      #4464

      jamesl
      Participant

      22 posts

      Thanks Nigel. I used the address postmaster@loveluck.net (which does exist) and everything works fine.

      I still have my PGV site and I tried creating a bogus user. The messages did have the ‘From’ address as
      phpgedview-noreply@loveluck.net (which does not exist). So what I didn’t understand is why the non-existent address works for PGV but not for kiwitrees. However, It’s not worth pursuing this, since you did resolve the problem for kiwitrees.

      Thanks for your patience!

      James

    Viewing 8 posts - 1 through 8 (of 8 total)

    You must be logged in to reply to this topic.