Search Forums
Forums
Kiwitrees on Twitter
    Tags

    access level, MAC, date, 2.0, data errors, logout, 3.2.2, 3.2.0, 3.0.0. setup, googlemaps, favourite, fatal error, tab, MYSQL, 3.1.1, missing data, roadmap, events of close relatives, married, help, HTML block, html, danish, simpl_grey, wish, login, sanity, message contactform, upgrade, Support/Bug Reporting, googlemap, advent, immigration, theme, future, stories, Relationship, individual resource, gallery, calendar.php issue, default individual, validation, footer, hover, getClientIp, surname, family facts, margin, survey, husband, F.A.B., sanity checker, delete, session, ckeditor, Advanced search, simpl_research, xenea, login failure, batch update

    Topic:   Missing Source details  

    This topic contains 6 replies, has 2 voices, and was last updated by kiwi kiwi 1 year, 10 months ago.

    Viewing 7 posts - 1 through 7 (of 7 total)
    • Author
      Posts
    • #5271
      macalter
      macalter
      Participant

      536 posts

      When I do a search for S4, the page returns the title of the Source, but nothing else. If I do a list of Sources, it does appear (Wikipedia), but doesn’t display anything more when clicked.

      -----
      Kiwitrees:
      "A-D connections 3.3.0 (rev)"
      PHP 5.6.29 Fast CGI

      "The Royals 3.3.0.."
      PHP 7.0 Fast CGI
      mySQL server: 5.1.56
      MacOS: 10.11.6  (El Capitan)
      Browsers (mac): Safari  Version 10.1.1 (11603.2.5);  Firefox 53.0.2
      [updated: 22 May 2017]

      #5272
      kiwi
      kiwi
      Keymaster

      1443 posts

      When I do a search for S4, the page returns the title of the Source, but nothing else. If I do a list of Sources, it does appear (Wikipedia), but doesn’t display anything more when clicked.

      If you look at the URL you will see that doing either of those things goes to the same place, which is why you get the same result.

      If you look at the ‘page source’ you will find that (eventually) the page load times-out due to insufficient memory. That source has links to 2,739 individuals, 1,025 families, and 951 media objects. Your server is not configured to handle that much. It only has a ‘max_execution_time’ of 30 secs.

      Looking at the fatal error in detail it is actually failing on file “calendar.php”, line 158. That code is trying to calculate a month number involving the Jewish month ‘ADS’. So I suspect you have a record somewhere, linked to S4, with some ‘strange’ data. But you will not be able to find it without first getting enough ‘max_execution_time’ to allow the page to load.

      Nigel

      My personal kiwitrees site is www.our-families.info

      #5273
      kiwi
      kiwi
      Keymaster

      1443 posts

      Actually, trying it again a couple of times, it fails on a different file each time. This confirms that it is no particular code that is causing the problem, but that time is exceeded at various places depending on the load each time. So only what can be expected with a 30 sec limit.

      Here is a sample of the error:

      Fatal error: Maximum execution time of 30 seconds exceeded in /home/your domain/library/WT/Date.php on line 276

      Nigel

      My personal kiwitrees site is www.our-families.info

      #5274
      macalter
      macalter
      Participant

      536 posts

      I had my host raise the limit. Do I have to do any change in kiwitrees settings?

      -----
      Kiwitrees:
      "A-D connections 3.3.0 (rev)"
      PHP 5.6.29 Fast CGI

      "The Royals 3.3.0.."
      PHP 7.0 Fast CGI
      mySQL server: 5.1.56
      MacOS: 10.11.6  (El Capitan)
      Browsers (mac): Safari  Version 10.1.1 (11603.2.5);  Firefox 53.0.2
      [updated: 22 May 2017]

      #5275
      kiwi
      kiwi
      Keymaster

      1443 posts

      Possibly. Check what you have in admin>site config>php time limit

      It needs to be empty (displaying ‘click to edit’) or have a value equal to or greater than whatever your host has provided.

      Unfortunately php can’t tell us how much time you need, so your host will need to keep raising it until it works. If they impose an absolute limit ask them for a temporary increase to allow investigation of what is causing the problem, if there is any. But hopefully that won’t be necessary, and that there is no problem other than the time out.

      Nigel

      My personal kiwitrees site is www.our-families.info

      #5276
      macalter
      macalter
      Participant

      536 posts

      My provider changed settings to:
      post_max_size = 105M
      max_execution_time = 500
      max_input_time = 500
      memory_limit = 128M

      These show in the PHP configuration with no option to ‘click to edit’

      -----
      Kiwitrees:
      "A-D connections 3.3.0 (rev)"
      PHP 5.6.29 Fast CGI

      "The Royals 3.3.0.."
      PHP 7.0 Fast CGI
      mySQL server: 5.1.56
      MacOS: 10.11.6  (El Capitan)
      Browsers (mac): Safari  Version 10.1.1 (11603.2.5);  Firefox 53.0.2
      [updated: 22 May 2017]

      #5277
      kiwi
      kiwi
      Keymaster

      1443 posts

      🙂

      Actually I never mentioned “PHP configuration”, becasue there is no such place. I guess you are looking at “PHP Information”

      I said “admin>site config>php time limit”, and yes I did miss out one part, but assumed you knew your way around the admin screens by now 🙂

      It should be: “admin>site administration>site config>php time limit” as shown here:
      Screenshot-2015-08-30-13.54.05

      But there is nothing there you need to change.

      Nigel

      My personal kiwitrees site is www.our-families.info

      Attachments:
      You must be logged in to view attached files.
    Viewing 7 posts - 1 through 7 (of 7 total)

    You must be logged in to reply to this topic.