Search Forums
Forums
Kiwitrees on Twitter
    Tags

    media, batch update, CREM, locked out, research tasks, access level, Support/Bug Reporting, CHR, family facts, time, places, hover, pages, date, translation, simpl_grey, sidebar, survey, burial, folder, roadmap, married, html, bug reporting, tags, icons, wish, ID notes, 2.0.2, webtrees 1.4.4.1, family, GEDCOM errors, fancy image bar, 3.3.0, cookie, My Page, Batch Updates, duplicates, calendar.php issue, notes, googlemaps, login, fixing errors, prison, resources, simpl_research, internal messaging, contacts, login upgrade, road map, googlemap. modified, add missing death, dates, add_asso_facts, charts, custom text, latest version, json, custom modules, contact links

    Topic:   Media path  

    This topic contains 9 replies, has 2 voices, and was last updated by macalter macalter 10 months ago.

    Viewing 10 posts - 1 through 10 (of 10 total)
    • Author
      Posts
    • #9017
      macalter
      macalter
      Participant

      462 posts

      Did something wrong: Upgraded okay. Wanted to set the path to images instead of always having to change in “manage media”. From data, I have mine 2 levels down. Changed and think that’s what gave errors:

      ERROR 2: mkdir(): Permission denied
      0 Error occurred on in function mkdir
      1 called from line 129 of file File.php in function mkdir
      2 called from line 79 of file I18N.php in function init
      3 called from line 487 of file session.php in function require
      4 called from line 25 of file index.php

      Warning: mkdir(): Permission denied in /home/user/mydomain.com/sub/library/WT/File.php on line 129

      Fatal error: Uncaught Zend_Cache_Exception: cache_dir “/cache” must be a directory in /home/user/mydomain.com/sub/library/Zend/Cache.php:209 Stack trace: #0 /home/user/mydomain.com/sub/library/Zend/Cache/Backend/File.php(177): Zend_Cache::throwException(‘cache_dir “/cac…’) #1 /home/user/mydomain.com/sub/library/Zend/Cache/Backend/File.php(128): Zend_Cache_Backend_File->setCacheDir(‘/cache’) #2 /home/user/mydomain.com/sub/library/Zend/Cache.php(153): Zend_Cache_Backend_File->__construct(Array) #3 /home/user/mydomain.com/sub/library/Zend/Cache.php(94): Zend_Cache::_makeBackend(‘File’, Array, false, false) #4 /home/ftpmyra/alterfamily.woodengems.com/wtkiwi/library/WT/I18N.php(80): Zend_Cache::factory(‘Core’, ‘File’, Array, Array) #5 /home/user/mydomain.com/subincludes/session.php(487): WT_I18N::init() #6 /home/user/mydomain.com/sub/index.php(25): require(‘/home/ftpmyra/a…’) #7 {main in /home/user/mydomain.com/sub/library/Zend/Cache.php on line 209

      -----
      [updated: 01 Apr 2018]
      MacOS: 10.11.6  (El Capitan)
      Safari  11.1;  Firefox 59.0.2

      PHP 7.1 Fast CGI
      mySQL server: 5.1.56

      Kiwitrees:
      "The Royals 3.3.3 (03)" <royals.rbcsolutions.ca>

      "Rebbes of Ger 3.3.3 (03)" <private>

      "Uncle Ummie's Journal 3.3.3 (03)" <private>

      #9018
      kiwi
      kiwi
      Keymaster

      1636 posts

      Did something wrong: Upgraded okay. Wanted to set the path to images instead of always having to change in “manage media”. From data, I have mine 2 levels down. Changed and think that’s what gave errors:

      Show me what you have actually changed.

      Nigel
      My personal kiwitrees site is www.our-families.info
      #9019
      macalter
      macalter
      Participant

      462 posts

      To get this:

      I changed this, but in wrong place:

      should have been after “media” on 2nd line but typed as part of full path “data/media/photos”

      -----
      [updated: 01 Apr 2018]
      MacOS: 10.11.6  (El Capitan)
      Safari  11.1;  Firefox 59.0.2

      PHP 7.1 Fast CGI
      mySQL server: 5.1.56

      Kiwitrees:
      "The Royals 3.3.3 (03)" <royals.rbcsolutions.ca>

      "Rebbes of Ger 3.3.3 (03)" <private>

      "Uncle Ummie's Journal 3.3.3 (03)" <private>

      Attachments:
      #9023
      kiwi
      kiwi
      Keymaster

      1636 posts

      … but typed as part of full path “data/media/photos”

      But you can’t type in that space. It doesn’t accept anything.

      But anyway, sounds like you are saying it’s OK now?

      Nigel
      My personal kiwitrees site is www.our-families.info
      #9024
      macalter
      macalter
      Participant

      462 posts

      No, not better.

      -----
      [updated: 01 Apr 2018]
      MacOS: 10.11.6  (El Capitan)
      Safari  11.1;  Firefox 59.0.2

      PHP 7.1 Fast CGI
      mySQL server: 5.1.56

      Kiwitrees:
      "The Royals 3.3.3 (03)" <royals.rbcsolutions.ca>

      "Rebbes of Ger 3.3.3 (03)" <private>

      "Uncle Ummie's Journal 3.3.3 (03)" <private>

      #9025
      kiwi
      kiwi
      Keymaster

      1636 posts

      I don’t think I can help much. I have absolutely no understanding of what you have actually done.

      I can probably understand better if you give me access to your site.

      Nigel
      My personal kiwitrees site is www.our-families.info
      #9028
      macalter
      macalter
      Participant

      462 posts

      Family matters prevent me from attending to this catastrophe right now. I did try a re-install but to no avail. All I wanted to do is change default path for my media

      -----
      [updated: 01 Apr 2018]
      MacOS: 10.11.6  (El Capitan)
      Safari  11.1;  Firefox 59.0.2

      PHP 7.1 Fast CGI
      mySQL server: 5.1.56

      Kiwitrees:
      "The Royals 3.3.3 (03)" <royals.rbcsolutions.ca>

      "Rebbes of Ger 3.3.3 (03)" <private>

      "Uncle Ummie's Journal 3.3.3 (03)" <private>

      #9029
      kiwi
      kiwi
      Keymaster

      1636 posts

      I don’t think I can help much. I have absolutely no understanding of what you have actually done.

      I can probably understand better if you give me access to your site.

      Nigel
      My personal kiwitrees site is www.our-families.info
      #9030
      kiwi
      kiwi
      Keymaster

      1636 posts

      If access to the site is still not possible, then I will need access to the server.

      Nigel
      My personal kiwitrees site is www.our-families.info
      #9042
      macalter
      macalter
      Participant

      462 posts

      Dreamhost restored mySQL database and my website to version 3.3.0 state. It’s working fine. I lost the file I kept of snapshots for various config pages so am capturing those again. When I am able to, will do the upgrade. In between, I upgraded The Royals and it’s fine so I’ll never know what I did but did a good job of it!

      I also want to remove all various renditions I’ve had of my site (as far back as a working PGV & webtrees copy) so I’m not trying to figure out what’s what. The config file in data is quite helpful.

      Not sure if you meant by granting access if you meant FTP access. Dreamhost was explaining this to me which is how the restoration happened during our “chat” (live chat support).

      -----
      [updated: 01 Apr 2018]
      MacOS: 10.11.6  (El Capitan)
      Safari  11.1;  Firefox 59.0.2

      PHP 7.1 Fast CGI
      mySQL server: 5.1.56

      Kiwitrees:
      "The Royals 3.3.3 (03)" <royals.rbcsolutions.ca>

      "Rebbes of Ger 3.3.3 (03)" <private>

      "Uncle Ummie's Journal 3.3.3 (03)" <private>

    Viewing 10 posts - 1 through 10 (of 10 total)

    You must be logged in to reply to this topic.