Search Forums
Forums
Kiwitrees on Twitter
    Tags

    sanity checker, kiwitrees, gallery, gender change, follow, type, ID notes, responsive menus, MYSQL, Support/Bug Reporting, My Page, 3.2.1, 3.0.0, white screen, wish, cookie, 3.2.0, Advanced search, age, progress, kiwitrees theme, calendar.php issue, Extra menus, statistics, simpl_pages, colors, privacy, simpl_research, default individual, GEDCOM errors, future, merge, server, MAC, tags, date, image, mysql5.7, burial, emmigration, blocks, widget, error, save settings, I18N, order, users, access level, tab, add_asso_facts, fancy tree view, latest version, pop-ups, Georgian, title, login upgrade, multiple marriages, reports, googlemaps, index

    Topic:   kiwitrees compatability with php 5.6  

    This topic contains 2 replies, has 2 voices, and was last updated by macalter macalter 1 year, 11 months ago.

    Viewing 3 posts - 1 through 3 (of 3 total)
    • Author
      Posts
    • #4786
      kiwi
      kiwi
      Keymaster

      1431 posts

      I thought I would start a topic to capture any issues anyone finds using php 5.6. If you have what you think might be a 5.6 issue add it here. I will investigate each one, and if it’s not 5.6 related I’ll move the issue to another topic.

      To date we have had feedback from two users:

      1 – reporting that kiwitrees is working fine (PHP updated on an existing kiwitrees (3.0.0) installation)
      2 – reporting a number of Zend library errors.

      1 is obviously good news, but 2 is hard to confirm.

      Now that ver. 3.1.0 is released I have started my own testing. So far I have not seen any Zend errors myself.

      I have identified some issues setting up a new installation of kiwitrees though. They are already fixed ready for a 3.1.1 release. I will not release that yet though. Better to wait for more testing. It will not effect any existing users, and as we require membership of kiwitrees.net for new users I will know when any of those are likely to need this.

      Nigel

      My personal kiwitrees site is www.our-families.info

      #4788
      kiwi
      kiwi
      Keymaster

      1431 posts

      Zend issues

      I may have found the problem. I have been able to reproduce this error message:

      Deprecated: iconv_set_encoding[]: Use of iconv.internal_encoding is deprecated in C:\xampp\htdocs\kiwitrees\library\Zend\Locale\Format.php on line 313

      Not sure if that is the one previously seen, but it will be easy enough to fix, I think.

      EDIT (22/07/2015): Zend issues fixed.

      Nigel

      My personal kiwitrees site is www.our-families.info

      #4796
      macalter
      macalter
      Participant

      534 posts

      I just set my “royalty” site to 5.6 Fast CGI. Not sure if I’ll know what’s PHP related but will see.

      -----
      Kiwitrees:
      "A-D connections 3.3.0 (rev)"
      PHP 5.6.29 Fast CGI

      "The Royals 3.3.0.."
      PHP 7.0 Fast CGI
      mySQL server: 5.1.56
      MacOS: 10.11.6  (El Capitan)
      Browsers (mac): Safari  Version 10.1.1 (11603.2.5);  Firefox 53.0.2
      [updated: 22 May 2017]

    Viewing 3 posts - 1 through 3 (of 3 total)

    You must be logged in to reply to this topic.