Search Forums
Forums
Kiwitrees on Twitter
    Tags

    name, survey, .po, blocks, error, calendar.php issue, performance, multiple marriages, .mo, last change date, redirect, title, emmigration, cousins, administration pages, themes, Favourites, time, individual resource, Georgian, calendar, library, family fact, access level, margin, resources, default individual, search, custom text, login, 1939 Register, simpl_grey, ID facts, widget, descendants, style, Administration, logs, lists, custom modules, bug, charts, edit menu, journal, data errors, NCHI, wish, 500, white screen, road map, immigration, folder, Export/Import, events of close relatives, Relationship, dropbox. token, pdf, colors theme, updates, 3.3.0

    Topic:   Invalid JSON  

    This topic contains 11 replies, has 2 voices, and was last updated by macalter macalter 1 year, 9 months ago.

    Viewing 12 posts - 1 through 12 (of 12 total)
    • Author
      Posts
    • #5427
      macalter
      macalter
      Participant

      536 posts

      DataTables warning: table id=media-table-8cbc11957151b692355cdfe5f02102db – Invalid JSON response. For more information about this error, please see http://datatables.net/tn/1

      Have just visited my personal site after quite a long hiatus. Saw no images loaded so investigated. Had the above as pop up error. I visited the mentioned URL in Safari (Mac) but didn’t understand the instructions.

      The admin > media page had page full of this error.
      Deprecated: iconv_set_encoding(): Use of iconv.internal_encoding is deprecated in /home/user/alterfamily.woodengems.com/xxx/library/Zend/Locale/Format.php on line 313 (each repeat of error shows different line number

      Realized I was at 3.1.0. Am doing update to 3.1.1. Will that fix the problem?

      -----
      Kiwitrees:
      "A-D connections 3.3.0 (rev)"
      PHP 5.6.29 Fast CGI

      "The Royals 3.3.0.."
      PHP 7.0 Fast CGI
      mySQL server: 5.1.56
      MacOS: 10.11.6  (El Capitan)
      Browsers (mac): Safari  Version 10.1.1 (11603.2.5);  Firefox 53.0.2
      [updated: 22 May 2017]

      #5428
      kiwi
      kiwi
      Keymaster

      1449 posts

      Realized I was at 3.1.0. Am doing update to 3.1.1. Will that fix the problem?

      I think so, but too long since 3.1.1 was released so can’t say for sure. Let me know after you’ve upgraded and I’ll look into it if not fixed.

      (ps – please keep up to date – it really does help with bug tracing 🙂 )

      Nigel

      My personal kiwitrees site is www.our-families.info

      #5429
      macalter
      macalter
      Participant

      536 posts

      I was quite surprised that I wasn’t current.

      Just in midst of transferring files. Encouraged that you think it may help!

      -----
      Kiwitrees:
      "A-D connections 3.3.0 (rev)"
      PHP 5.6.29 Fast CGI

      "The Royals 3.3.0.."
      PHP 7.0 Fast CGI
      mySQL server: 5.1.56
      MacOS: 10.11.6  (El Capitan)
      Browsers (mac): Safari  Version 10.1.1 (11603.2.5);  Firefox 53.0.2
      [updated: 22 May 2017]

      #5430
      macalter
      macalter
      Participant

      536 posts

      The update didn’t work. Now I can’t even log in. Attempted to use the offline.txt file to block the error messages but that didn’t take.

      -----
      Kiwitrees:
      "A-D connections 3.3.0 (rev)"
      PHP 5.6.29 Fast CGI

      "The Royals 3.3.0.."
      PHP 7.0 Fast CGI
      mySQL server: 5.1.56
      MacOS: 10.11.6  (El Capitan)
      Browsers (mac): Safari  Version 10.1.1 (11603.2.5);  Firefox 53.0.2
      [updated: 22 May 2017]

      #5431
      kiwi
      kiwi
      Keymaster

      1449 posts

      Sounds like your upgrade is incomplete, probably resulting in a mix of old, new, and corrupt files.

      I would recommend deleting all except the /data folder and upload a completely fresh copy. Providing you leave /data alone no harm can be caused to your database or media files.

      What FTP software do you use? There is one commonly used product that regularly causes issues like this. Sorry but I can’t recall its name just now.

      If you would prefer me to do it, just email me the necessary FTP access details. I will be able to look at it in about 24 hours.

      Nigel

      My personal kiwitrees site is www.our-families.info

      #5432
      macalter
      macalter
      Participant

      536 posts

      There’s two FTP programs I use: Transmit and FIleZilla. The latter lets me have better view of what’s happening. I used it for my Royals site and it works okay.
      Did clean install. Same errors.

      -----
      Kiwitrees:
      "A-D connections 3.3.0 (rev)"
      PHP 5.6.29 Fast CGI

      "The Royals 3.3.0.."
      PHP 7.0 Fast CGI
      mySQL server: 5.1.56
      MacOS: 10.11.6  (El Capitan)
      Browsers (mac): Safari  Version 10.1.1 (11603.2.5);  Firefox 53.0.2
      [updated: 22 May 2017]

      #5433
      kiwi
      kiwi
      Keymaster

      1449 posts

      The admin > media page had page full of this error.
      Deprecated: iconv_set_encoding(): Use of iconv.internal_encoding is deprecated in /home/user/alterfamily.woodengems.com/xxx/library/Zend/Locale/Format.php on line 313 (each repeat of error shows different line number

      I just checked the code and I can confirm that the term “iconv.internal_encoding” doesn’t exist anywhere in the 3.1.1 code.

      So your upload has failed again.

      I also checked, and it is FileZilla that regularly causes upload failures, and equally often doesn’t provide any feedback to tell you it failed.

      If you would like me to do the upload for you just send access details.

      Nigel

      My personal kiwitrees site is www.our-families.info

      #5434
      kiwi
      kiwi
      Keymaster

      1449 posts

      Looking further (and before you try another upload) there is another possible / likely cause.

      the Zend library has code that checks the PHP version number.

      It does apply “iconv.internal_encoding” IF it finds that php is earlier than version 5.6.0.

      So double check that your A-D site IS still using 5.6.

      If it is, compare the contents of the file /library/Zend/Locale/Format.php as it exists on your server and as it exists in the kiwitrees 3.1.1 package before uploading. Go to the end of the file and compare the last few lines (from 1300 onwards.

      Nigel

      My personal kiwitrees site is www.our-families.info

      #5435
      macalter
      macalter
      Participant

      536 posts

      Gee, missed updating PHP as well. It was 5.5. Your download page may remind users but I’m using the same download from Royals so wasn’t at your site. Realized version when I looked at my signature in this forum, which I just updated too.

      Changed to 5.6 and meantime am deleting files. Will upload with Transmit.

      -----
      Kiwitrees:
      "A-D connections 3.3.0 (rev)"
      PHP 5.6.29 Fast CGI

      "The Royals 3.3.0.."
      PHP 7.0 Fast CGI
      mySQL server: 5.1.56
      MacOS: 10.11.6  (El Capitan)
      Browsers (mac): Safari  Version 10.1.1 (11603.2.5);  Firefox 53.0.2
      [updated: 22 May 2017]

      #5436
      macalter
      macalter
      Participant

      536 posts

      my site is alive.

      -----
      Kiwitrees:
      "A-D connections 3.3.0 (rev)"
      PHP 5.6.29 Fast CGI

      "The Royals 3.3.0.."
      PHP 7.0 Fast CGI
      mySQL server: 5.1.56
      MacOS: 10.11.6  (El Capitan)
      Browsers (mac): Safari  Version 10.1.1 (11603.2.5);  Firefox 53.0.2
      [updated: 22 May 2017]

      #5437
      kiwi
      kiwi
      Keymaster

      1449 posts

      my site is alive.

      That’s great. 🙂

      Will upload with Transmit.

      I don’t know that one, but presumably mac-specific. Filezilla is supposed to be good, and certainly popular. But every time I’ve seen a problem such as yours it has ALWAYS been when using Filezilla. I have no idea why as I’ve never used it myself.

      With a large upload such as kiwitrees (and especially the zend library part) it is common to have a few files that fail. More so if you have a slow(er) or busy internet connection. The problems really start when you don’t know the failures have happened. It seems that FZ doesn’t tell you about failures, or perhaps it does but it’s too well hidden to use??

      My personal favourite is FireFTP, an add-on to the Firefox browser. Being a browser component it has the advantage of always being available. No extra programme to load. The other thing I like is its very accessible (on upload screen) log system. That tells you exactly which files failed, and lets you simply re-send those. I find there are always a handful, and re-sending them always works.

      Nigel

      My personal kiwitrees site is www.our-families.info

      #5438
      macalter
      macalter
      Participant

      536 posts

      Installed the FireFTP and will give it a try next time I FTP. Default is Transmit but sometimes I want to see more details than it shows (file transfer). I have emailed FileZilla about another matter so will raise the issue if he returns reply.
      I usually like clean install but had wee bit of usage left on account due to massive download earlier (SQL/email backups) from web host. Had to wait the 24 hours for reset but wanted to start.

      -----
      Kiwitrees:
      "A-D connections 3.3.0 (rev)"
      PHP 5.6.29 Fast CGI

      "The Royals 3.3.0.."
      PHP 7.0 Fast CGI
      mySQL server: 5.1.56
      MacOS: 10.11.6  (El Capitan)
      Browsers (mac): Safari  Version 10.1.1 (11603.2.5);  Firefox 53.0.2
      [updated: 22 May 2017]

    Viewing 12 posts - 1 through 12 (of 12 total)

    You must be logged in to reply to this topic.