Search Forums
Forums
Kiwitrees on Twitter
    Tags

    advent, Fancy imagebar, survey, tab, missing data, html, Support/Bug Reporting, Require visitor authentication, simpl_research, menu, new feature, 1939 Register, 3.1, ASSO, mobile, kiwitrees theme, random_media, transifex, tags, family, future, blank screem, admin, default individual, errors, 2.0, pages, datatables, date, googlemap, fixing errors, research, click, chart, relationships, image, type, living, F.A.B., repo, sanity, add, .mo, illegitimate, beta, widget, kiwitrees 2.0.2, roadmap, fact, cousins, census assistant, MYSQL, server, logout, logs, backup, progress, 3.0.0 widgets, My Page, order

    Topic:   Incorrect/confusing handling of Media Type  

    This topic contains 10 replies, has 2 voices, and was last updated by kiwi kiwi 2 years, 1 month ago.

    Viewing 11 posts - 1 through 11 (of 11 total)
    • Author
      Posts
    • #4340
      clandav
      clandav
      Participant

      121 posts

      In checking out the media image size problem reported by jacoline under the topic ‘Statistics’ I discovered a few anomolies in the way in which media Type is handled:
      1. The Album tab displays various media types (eg ‘Card’, ‘Certificate’, ‘Document’ …) grouped together under the category ‘Comments’
      2. The display details function for an individual media item under the Album tab display, does not show the Type – this can only be seen by moving to Edit mode
      3. The old rather odd Type = ‘Electronic’ – which was introduced by Brian in PGV/webtrees I believe, to be used for census images – still appears as ‘Electronic’ on the media statistics pie chart, whereas it has been converted to ‘Census’ (thankfully!) on the Album tab display.

      Ron in France
      Website: http://www.clan-davies.org/webtrees/
      kiwitrees 3.3.0; PHP 7.0.18; MySQL 5.6.35 ;

      #4341
      kiwi
      kiwi
      Keymaster

      1443 posts

      🙂 Can I re-title this topic “Incorrect/confused user fails to read the manual”? 🙂

      Sorry Ron, no offence intended. I couldn’t resist.

      Have a read of this: https://kiwitrees.net/faqs/modules-faqs/album/ (there’s a link to it on the relevant config page at Administration > Tools > Album as well).

      Basically your concerns relate to the ‘default’ settings of what is a very extensively customisable Album tab.

      Nigel

      My personal kiwitrees site is www.our-families.info

      #4342
      kiwi
      kiwi
      Keymaster

      1443 posts

      PS – Brian didn’t invent the ‘electronic’ media type. It’s a standard part of the GEDCOM specification:

      SOURCE_MEDIA_TYPE:= {Size=1:15}
      [ audio | book | card | electronic | fiche | film | magazine |
      manuscript | map | newspaper | photo | tombstone | video ]
      A code, selected from one of the media classifications choices above, that indicates the type of
      material in which the referenced source is stored.

      They don’t specify what its purpose was meant to be though, so it’s your choice.

      Nigel

      My personal kiwitrees site is www.our-families.info

      #4343
      clandav
      clandav
      Participant

      121 posts

      Thanks Nigel – I stand corrected!

      Although still somewhat confused I’m afraid because having launched into the process of correcting my default settings I seem to have either hit an error – or, at least, something for which I seem unable to find an explanation/solution.

      My aim was to remove one group ‘Comments’ and add two new ones ‘Document’ and ‘Newspaper’, and reallocate the TYPES to the five resulting groups. However in the process I appear to have ‘lost’ a large proportion of the TYPES which were listed down the left side of the table. Reset does not change the situation. See screenshot.

      Can you please advise me how to recover from my apparent ineptitude.

      Ron in France
      Website: http://www.clan-davies.org/webtrees/
      kiwitrees 3.3.0; PHP 7.0.18; MySQL 5.6.35 ;

      Attachments:
      You must be logged in to view attached files.
      #4345
      kiwi
      kiwi
      Keymaster

      1443 posts

      Ron

      That doesn’t look like ineptitude to me. But also not an issue I’ve come across before and haven’t been able to replicate it today.

      However, there was an issue with another user’s Album tab a few weeks ago that I fixed. It related to it’s use in a multi-language environment, but it’s possible my corrections for that have also fixed the issue you have found.

      Try the attached replacement album module and see if improves things.

      Nigel

      My personal kiwitrees site is www.our-families.info

      Attachments:
      You must be logged in to view attached files.
      #4350
      clandav
      clandav
      Participant

      121 posts

      Thanks Nigel,

      That seems to have done the trick. The five groups are now accepted with the full list of TYPES appropriately allocated across groups. The only outstanding problem is that the title of the ‘Documents’ group still appears as ‘Comments’ on the Album Tab display.

      Ron in France
      Website: http://www.clan-davies.org/webtrees/
      kiwitrees 3.3.0; PHP 7.0.18; MySQL 5.6.35 ;

      Attachments:
      You must be logged in to view attached files.
      #4352
      clandav
      clandav
      Participant

      121 posts

      P.S I should also have shown a screen shot of the module admin page – see attached

      Ron in France
      Website: http://www.clan-davies.org/webtrees/
      kiwitrees 3.3.0; PHP 7.0.18; MySQL 5.6.35 ;

      Attachments:
      You must be logged in to view attached files.
      #4362
      kiwi
      kiwi
      Keymaster

      1443 posts

      Ron

      Just a small piece of additional information in respect of the 2nd point in your initial post to this topic:

      2. The display details function for an individual media item under the Album tab display, does not show the Type – this can only be seen by moving to Edit mode

      I have now added a new paragraph to the Album FAQ page. to help with that. It says (with pictures):

      Review existing “TYPE” tags
      There are a few ways you can review your existing “TYPE” tags. Individually you can check and edit an object’s TYPE tag by selecting “View details” for any image, or by clicking the file name / title displayed [not the image itself] wherever it is displayed. To review the TYPE settings in bulk go to Administration > Media > Manage media. The TYPE tags for every image are displayed in the right-hand column there.

      Nigel

      My personal kiwitrees site is www.our-families.info

      #4363
      kiwi
      kiwi
      Keymaster

      1443 posts

      The only outstanding problem is that the title of the ‘Documents’ group still appears as ‘Comments’ on the Album Tab display.

      Yes, that’s a silly error in the English (en_GB) translation file (my error). It will be fixed in the next release. You could over-ride it for now with a custom language file if you prefer, or you could switch to US English for a while.

      Nigel

      My personal kiwitrees site is www.our-families.info

      #4366
      clandav
      clandav
      Participant

      121 posts

      I don’t think that’s an issue and can happily live with it until the next release – it certainly looks far better now than it did before the fix you provided. Thanks Nigel.
      As you weren’t able to replicate the problem, I’ll send you by e-mail details of the steps that led to the problem, in case that’s of help.

      Ron in France
      Website: http://www.clan-davies.org/webtrees/
      kiwitrees 3.3.0; PHP 7.0.18; MySQL 5.6.35 ;

      #4369
      kiwi
      kiwi
      Keymaster

      1443 posts

      As you weren’t able to replicate the problem, I’ll send you by e-mail details of the steps that led to the problem, in case that’s of help.

      Thanks. Hopefully I will be able to understand the issue and confirm that these later fixes resolved it, rather than just luck 😉

      Nigel

      My personal kiwitrees site is www.our-families.info

    Viewing 11 posts - 1 through 11 (of 11 total)

    You must be logged in to reply to this topic.