Search Forums
Forums
Kiwitrees on Twitter
    Tags

    pages, datatables, advanced, abbreviate, census assistant, marriage, mystyle, advent, events of close relatives, edit menu, dates, journal, edit options, error, request, redirect, ckeditor, clippings cart, session, fatal error, xenea, icons, json, release, html, themes, Fancy imagebar, NCHI, privacy, timeout, Google Maps, message contactform, performance, emigration, duplicates, multiple marriages, link, place, simpl_grey, batch update, library, 3.0.0, ID facts, transifex, mysql5.7, FAQ, validation, watermark, tags, fancy image bar, dead, blank screem, internal messaging, Batch Updates, blocks, reports, design, CHR, data errors, access level

    Tagged: ,

    Topic:   Google Maps flag issue  

    This topic contains 2 replies, has 2 voices, and was last updated by kiwi kiwi 2 years, 5 months ago.

    Viewing 3 posts - 1 through 3 (of 3 total)
    • Author
      Posts
    • #4142
      Roy
      Roy
      Participant

      110 posts

      Nigel:

      When attempting to change/add a flag while in tools/google maps/geographic data an error is thrown. Tested on 2 live sites and 1 local wamp site. Got the same error on your 3.0 beta test site. The error reads:

      “Fatal error: Call to undefined method WT_Stats::getAllCountries() in C:\xxxx\xxxx\kiwitree\modules_v3\googlemap\module.php on line 430.”

      On your 3.0 beta site the line number is 424.

      The flag files are in the proper folder; at least on my sites.

      Worked fine on ver 2.0.

      Should a bug report be filed?

      Roy

      #4147
      kiwi
      kiwi
      Keymaster

      1449 posts

      Should a bug report be filed?

      Thanks, yes a bug would be useful. I hope, when I look into this, that the change in line number on the demo site indicates that it is already fixed though. But the bug report does give a point of reference for others. I know I did some work on the flags soon after releasing 3.0.0, and would have copied those to the demo along with other GM changes. Not sure if this fix includes your issue or not.

      Nigel

      My personal kiwitrees site is www.our-families.info

      #4160
      kiwi
      kiwi
      Keymaster

      1449 posts

      Fix committed. See bug report: https://kiwitrees.net/bug-reporting/google-maps-flag/

      Nigel

      My personal kiwitrees site is www.our-families.info

    Viewing 3 posts - 1 through 3 (of 3 total)

    You must be logged in to reply to this topic.