Search Forums
Forums
Kiwitrees on Twitter
    Tags

    chart, cookie, responsive menus, .po, users, I18N, mystyle, kiwitrees, sanity, performance, Add a wife, future, statistics, family fact, prefix, abbreviate, MYSQL, ID notes, 2.0.2, translation, github, multiple marriages, colors, Default record, menu, pdf, Require visitor authentication, dead, menus, title, place, descendant, login, last change date, lists, Themes change, autocomplete, F.A.B., upgrade, edit interface, 3.3.0, fancy image bar, inactive, research tasks, lists individuals families, tools, 3.2.0, access roles, library, index, date, slideshow, relationships, missing data, descendants, emigration, white screen, marriage, surname, dropbox. token

    Topic:   Check (duplicate names)  

    This topic contains 12 replies, has 2 voices, and was last updated by macalter macalter 1 year, 3 months ago.

    Viewing 13 posts - 1 through 13 (of 13 total)
    • Author
      Posts
    • #5916
      macalter
      macalter
      Participant

      534 posts

      Just tried using the check button in Edit name and nothing happens. The save and close work.

      -----
      Kiwitrees:
      "A-D connections 3.3.0 (rev)"
      PHP 5.6.29 Fast CGI

      "The Royals 3.3.0.."
      PHP 7.0 Fast CGI
      mySQL server: 5.1.56
      MacOS: 10.11.6  (El Capitan)
      Browsers (mac): Safari  Version 10.1.1 (11603.2.5);  Firefox 53.0.2
      [updated: 22 May 2017]

      #5917
      kiwi
      kiwi
      Keymaster

      1431 posts

      Works OK for me. Two thoughts:

      1 – You didn’t miss that it created a further tab did you?

      2 – Anything unusual about the name record?

      If it’s reproducible, give me the Q number and I’ll take a look (might not be this evening though).

      Nigel

      My personal kiwitrees site is www.our-families.info

      #5918
      macalter
      macalter
      Participant

      534 posts

      Q4079. I take back about adding name. Just tried to add new name to hers and nothing happened. Fields (surname and married name) stayed empty on save! Couldn’t check for duplicate.

      This is the second record where I noticed the check failed (Q4078). First for the other two. Wanted to try more than one before posting.

      “Just” started. Didn’t change anything. Emptied cash in kiwitrees and browser. Logout/login.

      -----
      Kiwitrees:
      "A-D connections 3.3.0 (rev)"
      PHP 5.6.29 Fast CGI

      "The Royals 3.3.0.."
      PHP 7.0 Fast CGI
      mySQL server: 5.1.56
      MacOS: 10.11.6  (El Capitan)
      Browsers (mac): Safari  Version 10.1.1 (11603.2.5);  Firefox 53.0.2
      [updated: 22 May 2017]

      #5919
      kiwi
      kiwi
      Keymaster

      1431 posts

      It looks to me like your site is badly broken. I suspect you have a mixture of old and new files.

      The layout is part old-style (from the pop-ups), part new.

      Most of the javascript files are not loaded at all (thats why check duplicates is failing).

      Attached is what the edit name tab should look like in your theme/pallette.

      I fear you might need to delete all the files and start over. Didn’t this happen to you a few weeks / months back as well?

      Nigel

      My personal kiwitrees site is www.our-families.info

      Attachments:
      You must be logged in to view attached files.
      #5921
      macalter
      macalter
      Participant

      534 posts

      I’m just noticing it now. Never in 3.1.1. And, not after upgrading until I got to that record. Continues now with all other records. Very strange. It’s too late to start over. Will do it tomorrow.

      Are you implying to erase kiwitrees before reinstall versus just reinstall? Want to make sure I’m doing the method that will fix things.

      -----
      Kiwitrees:
      "A-D connections 3.3.0 (rev)"
      PHP 5.6.29 Fast CGI

      "The Royals 3.3.0.."
      PHP 7.0 Fast CGI
      mySQL server: 5.1.56
      MacOS: 10.11.6  (El Capitan)
      Browsers (mac): Safari  Version 10.1.1 (11603.2.5);  Firefox 53.0.2
      [updated: 22 May 2017]

      #5922
      kiwi
      kiwi
      Keymaster

      1431 posts

      I just checked – it last happened to you in November, I think when you updated to 3.1.1. Very similar problem, it just manifested at a different place. See this thread: https://kiwitrees.net/forums/topic/invalid-json/

      Same advice as then – delete everything except the /data folder and install from scratch. As before, its an FTP issue.

      By leaving /data the link to your database (config.ini.php) will stay, as will all your media objects, so once the files are in place you will be back to normal running immediately.

      You will lose:

      • Bug fixes downloaded since the release of 3.2.0 (i.e. the last week)
      • Any custom theme files – so take copies of those before deleting and then put them back in the new folders.

      Nigel

      My personal kiwitrees site is www.our-families.info

      #5933
      macalter
      macalter
      Participant

      534 posts

      Any custom theme files – so take copies of those before deleting and then put them back in the new folders.

      It was nice that with the mystyle.css files (and similar “personal”), whatever I did modify was there. Every time I attempt to customize the theme, I get distracted and never start. One day…..

      Before I proceed, I’m doing a lot of fixes. This gigatrees also does sanity check (different name). Includes a tone of stuff. I’m guilty of marrying children to parents or having them born after their parents die. Well, maybe I shouldn’t take full blame, I did inherit file from someone. (The checks might interest you.)

      Waiting for the new subdomain to propagate so I can install fresh.

      -----
      Kiwitrees:
      "A-D connections 3.3.0 (rev)"
      PHP 5.6.29 Fast CGI

      "The Royals 3.3.0.."
      PHP 7.0 Fast CGI
      mySQL server: 5.1.56
      MacOS: 10.11.6  (El Capitan)
      Browsers (mac): Safari  Version 10.1.1 (11603.2.5);  Firefox 53.0.2
      [updated: 22 May 2017]

      #5934
      kiwi
      kiwi
      Keymaster

      1431 posts

      This gigatrees also does sanity check (different name). Includes a tone of stuff. I’m guilty of marrying children to parents or having them born after their parents die. Well, maybe I shouldn’t take full blame, I did inherit file from someone. (The checks might interest you.)

      I know. It’s the inspiration for kiwitrees “Sanity checker” module – see the FAQ page.

      Nigel

      My personal kiwitrees site is www.our-families.info

      #5953
      macalter
      macalter
      Participant

      534 posts

      New subdomain. New database/tables. New install of kiwitrees. Just went to edit a name and same problems. Check doesn’t work. NAME doesn’t accept the Given/Surnames added. As previous, the only modification is a mystyle.css in colors that modifies Place hierarchy (you gave me the code); my own Fact images.

      -----
      Kiwitrees:
      "A-D connections 3.3.0 (rev)"
      PHP 5.6.29 Fast CGI

      "The Royals 3.3.0.."
      PHP 7.0 Fast CGI
      mySQL server: 5.1.56
      MacOS: 10.11.6  (El Capitan)
      Browsers (mac): Safari  Version 10.1.1 (11603.2.5);  Firefox 53.0.2
      [updated: 22 May 2017]

      #5954
      kiwi
      kiwi
      Keymaster

      1431 posts

      See this topic https://kiwitrees.net/forums/topic/possible-name-field-bug/#post-5925

      Try the same step I asked Roy to try. Let me know what errors are reported.

      Nigel

      My personal kiwitrees site is www.our-families.info

      #5955
      macalter
      macalter
      Participant

      534 posts

      If you meant turn on developer’s tools, this is what I found using Firefox show error console. Hope it’s what you mean. Unlike Roy, my install was clean, not ugrade.

      [Error] TypeError: ‘undefined’ is not an object (evaluating ‘frm.NPFX.value’)
      generate_name (edit_interface.php, line 328)
      [Error] TypeError: ‘undefined’ is not an object (evaluating ‘frm.NPFX.value’)
      updatewholename (edit_interface.php, line 362)
      onkeyup (edit_interface.php, line 208)
      [Error] TypeError: ‘undefined’ is not an object (evaluating ‘frm.NPFX.value’)
      updatewholename (edit_interface.php, line 362)
      onblur (edit_interface.php, line 208)
      [Error] TypeError: ‘undefined’ is not an object (evaluating ‘frm.NPFX.value’)
      updatewholename (edit_interface.php, line 362)
      onkeyup (edit_interface.php, line 208)
      [Error] TypeError: ‘undefined’ is not an object (evaluating ‘frm.NPFX.value’)
      updatewholename (edit_interface.php, line 362)
      onblur (edit_interface.php, line 208)
      [Error] TypeError: ‘undefined’ is not an object (evaluating ‘frm.GIVN.value’)
      check_duplicates (edit_interface.php, line 465)
      onclick (edit_interface.php, line 208)
      [Error] TypeError: ‘undefined’ is not an object (evaluating ‘frm.NPFX.value’)
      updatewholename (edit_interface.php, line 362)
      onblur (edit_interface.php, line 208)

      -----
      Kiwitrees:
      "A-D connections 3.3.0 (rev)"
      PHP 5.6.29 Fast CGI

      "The Royals 3.3.0.."
      PHP 7.0 Fast CGI
      mySQL server: 5.1.56
      MacOS: 10.11.6  (El Capitan)
      Browsers (mac): Safari  Version 10.1.1 (11603.2.5);  Firefox 53.0.2
      [updated: 22 May 2017]

      #5957
      kiwi
      kiwi
      Keymaster

      1431 posts

      Excellent, yes that’s exactly what I needed. Problem solved – and a BIG red face from me :-((((

      The problem here, and also the problem Roy reported (https://kiwitrees.net/forums/topic/possible-name-field-bug/) are both connected to the same file “/includes/functions/functions_edit.php.

      That in turn is connected to this topic: https://kiwitrees.net/forums/topic/marriage-type-selector-broken/ where I included a fix in the form of a replacement for that file.

      BUT I included the WRONG FILE 🙁 I actually included a 3.1.1 version (fixed for the marriage TYPE issue) instead of the 3.2.0 version with same fix. Caused by too many files of the same name open at the same time (see I AM human……) That broke many issues, most which you haven’t yet even noticed) in the new edit tabs. I of course had only the correct file in all my systems, hence why I couldn’t reproduce your issues.

      Please now go to the original topic (https://kiwitrees.net/forums/topic/marriage-type-selector-broken/ ) and re-download the fix from there. I have just replaced the attachment with a very carefully tested correct file. I don’t want to confuse things by putting copies anywhere else.

      Nigel

      My personal kiwitrees site is www.our-families.info

      #5960
      macalter
      macalter
      Participant

      534 posts

      Hee, hee. And hear I thought you didn’t want me populating the world with more Henrys and the like. Will add file now.

      -----
      Kiwitrees:
      "A-D connections 3.3.0 (rev)"
      PHP 5.6.29 Fast CGI

      "The Royals 3.3.0.."
      PHP 7.0 Fast CGI
      mySQL server: 5.1.56
      MacOS: 10.11.6  (El Capitan)
      Browsers (mac): Safari  Version 10.1.1 (11603.2.5);  Firefox 53.0.2
      [updated: 22 May 2017]

    Viewing 13 posts - 1 through 13 (of 13 total)

    You must be logged in to reply to this topic.