Search
Forums
Topic Information
ForumSupport for kiwitrees
Authormacalter
Last activity1 week, 6 days ago
StatusOpen
Replies4
Voices2
Participantsmacalter, kiwi
Actions
Tags

sanity checker, dates, zend, 7.0, update, pages, slideshow, login, NCHI, session, individual resource, bug sql error, hover, bug, roadmap, request, 3.0.0, fancy image bar, HTML block, marriage, updates, family facts, emigration, message contactform, 3.0.0. setup, margin, person, add, 1939 Register, survey, GDBR, nickname, title, time, error, multiple marriages, immigration, Favourites, source, Require visitor authentication, flags, tab, gettext, fatal error, event, getClientIp, index, news module, descendant, xmas, fancy tree view, stories, contacts, contact links, divorce, Add a wife, transifex, custom text, illegitimate, dropbox. token

Kiwitrees on Twitter

    Topic:   Blank home page  

    Viewing 5 posts - 1 through 5 (of 5 total)
    • Author
      Posts
    • #11051
      macaltermacalter
      Participant

      656 posts

      I ventured over to my The Royals and it said 3.3.5. Blank memory so I did an install of 3.3.6. Home page was blank and that’s when I remembered: I did have 3.3.6 installed and you “fixed” blank home page by having me check Modules. Site is okay.

      Is my download of 3.3.6 defective or is there a glitch in 3.3.6? I always like to have a backup (application) available.( Mine does have the file you changed yesterday)

      -----
      [updated: 23 Nov 2019]
      MacOS: 10.11.6  (El Capitan)
      Safari  11.1.2;  Firefox 69.0.2
      PHP 7.2 Fast CGI

      Alter-Drukarsh connections... 3.3.6 <private>
      The Royals 3.3.6 <royals.rbcsolutions.ca
      /index.php?ged=royals>

      The Gerrer Rebbes 3.3.6 <royals.rbcsolutions.ca>

      #11053
      kiwikiwi
      Keymaster

      1849 posts

      There’s no problem with the 3.3.6 download that I (or anyone else who has upgraded to it – which is quite a few people) am aware of.

      I also cannot think of any possible glitch that would cause you to lose all module access settings. I’ve never seen that happen on any other installation.

      Also, are you saying that your site (The Royals) said it was at 3.3.5 when in fact it was at 3.3.6? If so, then that is a definite problem in your upgrade process. If all files copy over to your server correctly, then the site will say it is at the correct (3.3.6) version.

      A couple of questions about your upgrades:

      1 – what version are you upgrading from? If from 3.3.5 I would expect no issues. It was a very simple upgrade, with no major changes. But if from a much older version, then there might be some complications. Did you read the Upgrade FAQ page?

      2 – What are the exact steps you take in your upgrade process?

      Nigel
      My personal kiwitrees site is www.our-families.info
      #11054
      macaltermacalter
      Participant

      656 posts

      I used an incorrectly labelled hyperlink to my site (from my browser) and reacted too soon when I saw 3.3.5. But, that said, the install “overwrite” produced the same results as the initial install I did of 3.3.6. (There’s a thread here somewhere which is how I corrected the problem).

      I’ll download a fresh copy to keep on hand.

      -----
      [updated: 23 Nov 2019]
      MacOS: 10.11.6  (El Capitan)
      Safari  11.1.2;  Firefox 69.0.2
      PHP 7.2 Fast CGI

      Alter-Drukarsh connections... 3.3.6 <private>
      The Royals 3.3.6 <royals.rbcsolutions.ca
      /index.php?ged=royals>

      The Gerrer Rebbes 3.3.6 <royals.rbcsolutions.ca>

      #11055
      kiwikiwi
      Keymaster

      1849 posts

      It really would be very valuable to understand how this “blank page” is being caused, in case it happens to anyone else.

      Your previous forum topic about it was https://kiwitrees.net/forums/topic/update-3-3-6/

      But that doesn’t tell us much about the steps you take in the upgrade process. For example, you clearly change the GEDCOM title (to add ‘3.3.6’ to it) but didn’t mention it in explaining what you did. I really need to know every step, so I can try to replicate it.

      The privacy settings that are set when you enable, modules are stored only in the database. Upgrading the files can have absolutely no impact on those settings unless something is written in the code that tells it to actually change those settings – and I have never done that for any upgrade, ever!

      Currently, I can only think that it’s a MAC issue (though why upgrading software on a MAC should change something on your server’s database I cannot imagine), or something you do in your upgrade that no-one else does.

      Detailed answers to my questions 1 and 2 in the previous post would, therefore, be very helpful.

      Nigel
      My personal kiwitrees site is www.our-families.info
      #11056
      macaltermacalter
      Participant

      656 posts

      I updated The Royals to 3.3.6 by downloading the zip file and unzipping.
      Backup GEDCOM to server.

      Clear cache (no particular reason, just habit).

      Using FtP, I upload all files (excluding “data folder”) to server. This is same method as always.
      As per the initial forum topic posted, I went to log in and the home page, root of site, was blank. That’s when I remembered I’d been this route before and the 3.3.5 was ONLY bad housekeeping at my end in terms of the various bookmarks I keep on my browsers (now 3). I knew from your reply to go to the /admin.php, log in, fix modules which were all unchecked.

      I’m trying to recall if the same thing happened when I updated my second install. As shown in my sig, I keep two installs. Quite sure it did and fixed same way.

      This is the only time I’ve ever experienced the problem so I doubt it being platform-based (Mac vs PC). And, true, no one else posted the same problem. My updating the two sites were done 28 October. Then another a day or two ago.

      -----
      [updated: 23 Nov 2019]
      MacOS: 10.11.6  (El Capitan)
      Safari  11.1.2;  Firefox 69.0.2
      PHP 7.2 Fast CGI

      Alter-Drukarsh connections... 3.3.6 <private>
      The Royals 3.3.6 <royals.rbcsolutions.ca
      /index.php?ged=royals>

      The Gerrer Rebbes 3.3.6 <royals.rbcsolutions.ca>

    Viewing 5 posts - 1 through 5 (of 5 total)
    • You must be logged in to reply to this topic.