Search Forums
Forums
Kiwitrees on Twitter
    Tags

    age, favourite, php 5.6, simpl_grey, 3.2.2, I18N, Google Maps, colors, survey, flags, reports, stories, Fancy imagebar, blocks, installation, IE problem, HTML block, transifex, users, marriage, 3.0.0, lists, simpl_research, css, watermark, access roles, follow, cookie, fact, ID notes, cousins, custom modules, html, event, mail, style, descendant, administration pages, ID facts, webtrees 1.4.4.1, googlemap. modified, defacto, duplicates, Add a wife, add missing death, contacts, multiple marriages, danish, place, chart, time, 3.0.0 widgets, Batch Updates, 1939 Register, admin, backup, json, roadmap, living, logout

    Tagged: ,

    Topic:   Add a media object  

    This topic contains 10 replies, has 2 voices, and was last updated by kiwi kiwi 10 months, 4 weeks ago.

    Viewing 11 posts - 1 through 11 (of 11 total)
    • Author
      Posts
    • #6867
      grebjiem
      grebjiem
      Participant

      105 posts

      When I add a new media object to a persons record e.g. birth or death Always the following pops up.

      The record with id …. was changed by another user since you last accessed it.
      Please reload the previous page to make sure you are working with the most recent record.

      I have now to reload, the page, close the tab with the announcement to reload. The mediaobject is in the album. Than add the media object again to the record. to show it by Birth or Death

      When I add a Media object to a family e.g. marriage, I can directly add the media object to the marriage without reloading and closing the tab.

      Is it possible to make adding media to a person like adding a mediaobject to a family?
      Or do I things not in the right order?

      #6868
      kiwi
      kiwi
      Keymaster

      1443 posts

      Is it possible to make adding media to a person like adding a mediaobject to a family?

      i ‘believe’ that the process is the same everywhere, so yes it is possible that you are not doing things in the right order. The error message usually means almost exactly what it says, that the individual has been edited and changed while you were adding the media. This is deliberate. It prevents conflicting edits, and also provides protection against hacking. A random code is created when you open a record for editing, and when you close (save) the re used. If you open the record twice, there will be two codes and so one of them will not match when you save.

      But it is also possible there is a bug, so I will need to EXACTLY replicate the steps you take. Can you list them carefully here – every step from opening the birth event to clicking the final ‘save’.

      Nigel

      My personal kiwitrees site is www.our-families.info

      #6869
      grebjiem
      grebjiem
      Participant

      105 posts

      I have send an e-mail with a lot of images, I will add the steps later in this topic

      #6870
      grebjiem
      grebjiem
      Participant

      105 posts

      1 click edit symbol a new tab opens
      2 click the + symbol by Media object a new tab opens
      3 add ID-number, upload media, chose type, add a title and save
      4 third tab closes, second tab says:The record with id …. was changed by another user since you last accessed it.
      Please reload the previous page to make sure you are working with the most recent record.
      5 Refresh first tab
      6 click edit symbol
      7 add the media and save
      8 close second tab.
      9 media is in the album and by the event.

      Steps 4 , 5, 6, 8 I don’t have to do by a marriage event.

      #6871
      kiwi
      kiwi
      Keymaster

      1443 posts

      Excellent, thanks. Now I can see the problem. Thanks for the images too. They really help/

      This is one of those issues that experiences users do not have – but they easily could. It has been “wrong” for ever! Personally I have always just ignored it, but I think it can be improved. To be certain try the same process, but do not add the ID number at the top – the first part of your point 3 in the list above:

      3 add ID-number

      The id number is not required here, and when you do add the ID number the system tries to add the image to the individual as well as to the birth event, and so creates a duplicate entry which fails the test.

      It is like this becasue the same screen is used here and also on the administration pages where you can add a media object when you are not on the individuals page (like linking).. If I am right, perhaps I can hide or “grey-out” that input field when there is an id number already available.

      Nigel

      My personal kiwitrees site is www.our-families.info

      1 user thanked author for this post.
      #6872
      grebjiem
      grebjiem
      Participant

      105 posts

      Had just tested this once, works better, but will do some tests tomorrow, For now it’s to late, I am going to sleep.

      #6873
      grebjiem
      grebjiem
      Participant

      105 posts

      Woke up early added some media objects as you said.
      This helps a lot! Sometimes it is better to ask before doing 🙂
      Think it helps when the field is grey, or shows already the ID number.

      #6874
      kiwi
      kiwi
      Keymaster

      1443 posts

      Think it helps when the field is grey, or shows already the ID number.

      I’m glad that helped. I have now found a solution. When the ID is not required then that field will not appear at all (next release).
      But your query also alerted me to other small problems on that screen, which I have also fixed. I’ll explain these tomorrow (too late tonight😉).

      Nigel

      My personal kiwitrees site is www.our-families.info

      #6878
      kiwi
      kiwi
      Keymaster

      1443 posts

      But your query also alerted me to other small problems on that screen, which I have also fixed.

      So, the other problems were these:
      1 – (image 1) – The add media field you used was only displayed by a chance error. You have selected “yes” for the setting “Use full source citations”. But that setting should only add the Quality (QUAY) and source DATE options. So although it is right to have that media input field, it should be there always, not just when you select “Use full source citations”. It is now fixed so you can always add a media object to an existing source.

      2 – (image 2) – not sure if you realised, but the add media field you were using there is part of the SOURce tag for the birth. That is different to adding a media object to the birth event itself. The problem is that it can be hard to see what is part of the source and what is part of the birth event itself on the edit screen unless you have a good understanding of what each label means. That is another problem that has been around a very long time. I have now improved, rather than “fixed”, that issue by arranging for the source-related fields to have a slightly different shade of background colour so it is clearer they are a group.

      Nigel

      My personal kiwitrees site is www.our-families.info

      Attachments:
      You must be logged in to view attached files.
      #6885
      grebjiem
      grebjiem
      Participant

      105 posts

      Thanks for the explanation.
      Adding a document to a source instead of the event, is more logical to me. But I understand if the source has a privacy setting the image is not displayed by the event to visitors (or members)

      #6886
      kiwi
      kiwi
      Keymaster

      1443 posts

      But I understand if the source has a privacy setting the image is not displayed by the event to visitors (or members)

      It is also hidden from everyone if (as I do) you set sources to be “closed” (not expanded”) by default. So I prefer to add all images (unless I specially want them to be private) to the event and not the source.

      I find that having all sources (and notes) always expanded makes many pages very long, and I don’t like to make people scroll any more than necessary.

      But it is all very personal preferences. That’s why we have options 🙂

      Nigel

      My personal kiwitrees site is www.our-families.info

    Viewing 11 posts - 1 through 11 (of 11 total)

    You must be logged in to reply to this topic.