Search Forums
Kiwitrees on Twitter

    locked out, blocks, BURI, descendant, 3.0.0, progress, custom, 7.0, Histo, googlemaps, Support/Bug Reporting, ASSO, language, survey, cousins, Extra menus, datatables, follow, chart, style, simpl_research, translation, menu, FAQ, transifex, 3.3.1, living, prefix, statistics, tags, random_media, folder, redirect, My Page, census assistant, fatal error, version, click, error, merge, privacy, add_asso_facts, .po, birth, fancy image bar, F.A.B., dropbox. token, 7.2, default individual, REFN, IE problem, 2.0.2, name, login upgrade, charts, Fancy imagebar, prison, missing data, Default record, support


    1610 posts

    Hi Derek.

    Just looked at your site, and the first person I looked at (I97) loaded in 0.364 seconds. So that makes it clear the issue is only when you are logged in.

    I pretty sure I know the problem though. The new “Relationship” feature on the Families tab can be very resource hungry if you set it to show complex relationships. Review the three groups of settings in the “Families tab settings” section (Administration > Tools > Relationship). First try clicking “Do not show any relationship” for all three just to see if that solves the problem. Then if it does try the other options to see which you find acceptable in the balance between usefulness and speed. Personally I use the simplest setting “Find a closest relationship via common ancestors” for all three in this area.

    For more information review the full FAQ (linked to on that administration page).

    My personal kiwitrees site is