A new version of kiwitrees is available

Version 3.1.1 of kiwitrees is ready for you to download now.

I realise this is only 10 days after the last upgrade but as PHP version 5.5 moved to being "Security Support Only" on 10th July I felt it was important to make a PHP 5.6 compatible version of kiwitrees available as soon as possible. However, kiwitrees does also continue to be compatible with any version of PHP since 5.3.

Details of other changes and enhancements can be seen on the Change lists.

---

PHP 5.6

The main changes needed to ensure kiwitrees is fully compatible with PHP 5.6 were in it's "Zend" library, which required updating to a new version; and in the enhanced encryption of passwords during initial set up, password change or adding a new user.

This last enhancement has further strengthened the security of passwords This also prompted other minor changes to the set-up process for new installations.

---

Mobile friendly displays

Work is continuing on making kiwitrees a little more mobile friendly. In this release the use of a drop-down menu system when you are on a small device is extended to all themes, and the home page blocks now stack vertically regardless of the 'normal' positioning.

These changes will be apparent when you are on any device with a screen width less than 1024 pixels.

---

Upgrading

The upgrade process for this version  from version 3.1.0 involves no special requirement.

See Upgrading for more detail.

---